Issues logging into the User Portal resolved, 08/31/2019 04:04PM CDT User Portal


Notification history

08/31/2019 04:04PM CDT
Update: At this time we have confirmed all systems are functional.
08/31/2019 01:26PM CDT
Update: At this time User Portal continues to be accessible as we continue to monitor and confirm full functionality. We will continue to update this page as we work to fully resolve the issue.
08/31/2019 12:42PM CDT
Update: We're have verified that User Portal is accessible at this time. We will continue to monitor the this until we're confident the issues have completely subsided. We will continue to update this page as we work to fully resolve the issue.
08/31/2019 11:42AM CDT
Update: Our engineers are currently investigating the issue and we apologize for any inconvenience caused for our customers. We will continue to update this page as we work to resolve the issue. In the meantime if you're needing support; you can reach us at 1-877-973-6446 
08/31/2019 10:45AM CDT
We are investigating an issue where customers are unable to log into their User Portal. Our engineers are currently investigating the issue and we apologise for any inconvenience caused for our customers. We will continue to update this page as we work to resolve the issue.